Join Our Ford Truck Forum Today

Document your Ford truck project here and inspire others! Login/Register to view the site with fewer ads.

sputtering

A_G

wuh?
3,188
74
Tulsa, Ok
Alright. so heres where im at. Ive been chasin bugs and what not.

over the past few months to a year. i could be cruising down the road about 55.. when some times it will sputter like its misfiring real bad, noticable vibration, here it from the exhuast. pedal feels dead. Ill gun it and once it hits bout 65 it stops suddenly and gets up and goes.

Where the heck do i start?

its becoming more frequent. the first time it happened i was in KC mo, thought i got bad batch of gas, but it has slowly becoming more frequent.

within the last 6 months, new cap, rotor, plugs, wires. Air filter. thats about it.

i havent done the fuel filter yet...could this be it....or something else?

im drivivng this truck 120 miles a day id like to get it back to as tip top running shape as i can. Save me some cash in the long run

as for the specs

1996 f150 2wd 302, 149,xxx (it will be 150xxx by friday)

thanks anthony
 

LEB Ben

Arrogant A-hole At-Large
34,919
1,124
outside your house
I'd go with fuel filter, maybe a glitch with the pump, are you able to get a psi guage on there? You noticed any 'smoke' coming outta the pipes when it sputters? Maybe a sensor.
 

A_G

wuh?
3,188
74
Tulsa, Ok
nope no smoke.

But if i let the truck set for more than 2-3 days it will start up. then die, and run like crap for a bit...and sometimes smoke.
 

A_G

wuh?
3,188
74
Tulsa, Ok
still havent got around to it...i did find that i have a failed plug wire..but that didnt fix it.

While i was in tulsa i did notice the when the truck got up to operating temp. i would be idling at a stomp light and give it gas and it would kinda sputter. You could hear it through the exhaust. kinda like it was over fueling and flooding out sorta. Maybe ive got a failed injector. I fixed all of my misfire problems and now power to DLC (broken wire) ill try and run the codes at work...
 
Top