Ford Truck Fanatics  



Home Gallery TOTM New Posts My Threads / My Replies Links Sponsors Calendar Arcade Calculators Fliers
Go Back   Ford Truck Fanatics > F-Series > Generations 8-9

Generations 8-9 1987-1996 F150 + 1987-1997 F250, F350

Reply
 
Thread Tools Display Modes
  #1  
Old 11-20-2019, 02:33 AM
Blue-Truck-Nut97's Avatar
Blue-Truck-Nut97 Blue-Truck-Nut97 is offline
 
Join Date: Oct 2019
Posts: 157
Blue-Truck-Nut97 is a jewel in the roughBlue-Truck-Nut97 is a jewel in the roughBlue-Truck-Nut97 is a jewel in the roughBlue-Truck-Nut97 is a jewel in the rough
1995 Powerstroke Sitting Disease

Ok, this one is throwing me for a loop here. A Powerstroke with a no start is indeed not uncommon, but I'd like some other opinions on this one.

95, F350 2 wheel drive. 4 door long bed. 281,000 miles. E40D.

Previous owner passed away late 2017/early 2018. Truck has been sitting.



Sent from my E6810 using Tapatalk
Reply With Quote
Sponsored Links
  #2  
Old 11-20-2019, 02:45 AM
Blue-Truck-Nut97's Avatar
Blue-Truck-Nut97 Blue-Truck-Nut97 is offline
 
Join Date: Oct 2019
Posts: 157
Blue-Truck-Nut97 is a jewel in the roughBlue-Truck-Nut97 is a jewel in the roughBlue-Truck-Nut97 is a jewel in the roughBlue-Truck-Nut97 is a jewel in the rough
Here's the preliminary details.

Filled HPOP before I ever cranked it.

Truck is stored inside above 58*F

Block heater is inoperative.

2 functional glow plugs.

42-45 psi fuel pressure, white smoke.

Tach moves to about 250 RPM.

Maintained 10+ volts at batteries during testing.

Passed buzz test, all 8.

Barro is low, but EBP and MAP are right.

ICP is leaking, so I unplugged it.

It tried to start, and smoked well, so I unhooked the glow plugs, and gave it a snort of ether. It ran on ether, but wouldn't light on it's own.

Now it gets interesting, I plugged the ICP back in, and hooked up Forescan.

ICP showed 0, cranked and it went up to 3350 PSI, as the IPR climbed from 14.3% to 55%. Then stayed at 328 PSI for a while, until I unhooked the laptop.

So, I'm thinking glow plugs and needed wizardry, then try again. Any suggestions?

Sent from my E6810 using Tapatalk

Last edited by Blue-Truck-Nut97; 11-20-2019 at 03:36 AM.
Reply With Quote
  #3  
Old 11-20-2019, 05:02 AM
heavydoc's Avatar
heavydoc heavydoc is offline
Moderator
Moderator
 
Join Date: Jan 2019
Location: WNC
Posts: 416
heavydoc is just really niceheavydoc is just really niceheavydoc is just really niceheavydoc is just really niceheavydoc is just really nice
I would pull the valve covers and crank it a see if you have an injector dumping the high pressure oil. I'm thinkin the right vavle cover, for 1 it is harder to get to, an 2 the icp reads in the left one
__________________
96 F-350 RCLB DRW 2WD
01 Excursion Limited 4WD
02 F-350 CCLB DRW 4WD
20 Kenworth T270

"DOC"
Reply With Quote
  #4  
Old 11-20-2019, 03:49 PM
Blue-Truck-Nut97's Avatar
Blue-Truck-Nut97 Blue-Truck-Nut97 is offline
 
Join Date: Oct 2019
Posts: 157
Blue-Truck-Nut97 is a jewel in the roughBlue-Truck-Nut97 is a jewel in the roughBlue-Truck-Nut97 is a jewel in the roughBlue-Truck-Nut97 is a jewel in the rough
Thank you Doc.

I should add, I did not pull the fuel filter and look, I may do that, just to see. Bowl heater has been unhooked years ago. Fuses good, IDM gets power, ( passed buzz test), PCM has power, ( tach and WTS work). Fuel level is verified at 1/2 tank.

Putting that in here for posterity if anybody comes along behind getting one running.

Sent from my E6810 using Tapatalk
Reply With Quote
  #5  
Old 11-20-2019, 08:49 PM
heavydoc's Avatar
heavydoc heavydoc is offline
Moderator
Moderator
 
Join Date: Jan 2019
Location: WNC
Posts: 416
heavydoc is just really niceheavydoc is just really niceheavydoc is just really niceheavydoc is just really niceheavydoc is just really nice
Your welcome let us know what you find


Sent from my iPhone using Tapatalk
__________________
96 F-350 RCLB DRW 2WD
01 Excursion Limited 4WD
02 F-350 CCLB DRW 4WD
20 Kenworth T270

"DOC"
Reply With Quote
  #6  
Old 11-21-2019, 12:53 AM
Blue-Truck-Nut97's Avatar
Blue-Truck-Nut97 Blue-Truck-Nut97 is offline
 
Join Date: Oct 2019
Posts: 157
Blue-Truck-Nut97 is a jewel in the roughBlue-Truck-Nut97 is a jewel in the roughBlue-Truck-Nut97 is a jewel in the roughBlue-Truck-Nut97 is a jewel in the rough
So today after the daily disasters, I once again approached this thing with fresh charged batteries and an attitude. HPOP was still full, with black oil from the pan, so I knew it was getting supplied. But, the rails in the heads were still not full. So, I cranked. And cranked. And cranked some more. With breaks for the starter to cool of course. Once I was getting good fuel smoke, it got a small snort if ether. ( Glow plugs unhooked of course).

And it started. It ran really rough, so I reached up and unplugged the leaking ICP sensor, and it immediately began improving. I ran it a while, and it was improving, but it needs some more run time for sure.

So, I'll get an air cleaner of some sort on it and run it some before going further. I did get both front wheels pointed the same direction again, so making progress.

Sent from my E6810 using Tapatalk
Reply With Quote
  #7  
Old 11-21-2019, 04:27 AM
heavydoc's Avatar
heavydoc heavydoc is offline
Moderator
Moderator
 
Join Date: Jan 2019
Location: WNC
Posts: 416
heavydoc is just really niceheavydoc is just really niceheavydoc is just really niceheavydoc is just really niceheavydoc is just really nice
Good deal
__________________
96 F-350 RCLB DRW 2WD
01 Excursion Limited 4WD
02 F-350 CCLB DRW 4WD
20 Kenworth T270

"DOC"
Reply With Quote
  #8  
Old 11-21-2019, 10:38 AM
Longjonsilver Longjonsilver is online now
pudding puller
 
Join Date: Oct 2019
Location: Upstate South Carolina
Posts: 102
Longjonsilver has a spectacular aura aboutLongjonsilver has a spectacular aura aboutLongjonsilver has a spectacular aura about
Good deal . I wonder why the oil drained back ?


Sent from my iPhone using Tapatalk
Reply With Quote
  #9  
Old 11-21-2019, 11:31 AM
heavydoc's Avatar
heavydoc heavydoc is offline
Moderator
Moderator
 
Join Date: Jan 2019
Location: WNC
Posts: 416
heavydoc is just really niceheavydoc is just really niceheavydoc is just really niceheavydoc is just really niceheavydoc is just really nice
The only way is injectors or o-rings


Sent from my iPhone using Tapatalk
__________________
96 F-350 RCLB DRW 2WD
01 Excursion Limited 4WD
02 F-350 CCLB DRW 4WD
20 Kenworth T270

"DOC"
Reply With Quote
  #10  
Old 11-21-2019, 11:34 AM
Blue-Truck-Nut97's Avatar
Blue-Truck-Nut97 Blue-Truck-Nut97 is offline
 
Join Date: Oct 2019
Posts: 157
Blue-Truck-Nut97 is a jewel in the roughBlue-Truck-Nut97 is a jewel in the roughBlue-Truck-Nut97 is a jewel in the roughBlue-Truck-Nut97 is a jewel in the rough
Not going to say for sure, but it's got lots of oil leaks, the ICP leaking may have let air in. Truck was neglected, abused, wrecked, abandoned for 2+ years, now I've got it.

Sent from my E6810 using Tapatalk
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:34 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Ford Truck Fanatics is not affiliated with or endorsed by Ford Motor Company.