Join Our Ford Truck Forum Today

Document your Ford truck project here and inspire others! Login/Register to view the site with fewer ads.

My poor truck

d-kuzmen

Master Ford Tech
2,094
75
Connecticut
Also I’m not 100% sure if the old style icp thread is the same as the valve cover mounted one. Been awhile since I changed one.
 
Also I’m not 100% sure if the old style icp thread is the same as the valve cover mounted one. Been awhile since I changed one.
Ironically they are. I have the newer style icp sensor in my truck because the old style icp sensor kept splitting. (Had 3 go in 2 years. Was tired of changing it) Its a common update for truck owners to do. No one can figure out why they keep splitting on the early builds when they never did on the 7.3's. The original icp sensor on the early 03/04 trucks used the same icp sensor as the 7.3's did. When they moved it to the pass side valve cover they went with a different style and more robust icp sensor. The early 03/04 owners been swapping them out and not having the icp sensors split. The dealerships are the only ones that refuse to and put the originals back in. But they work the same.
 
Wow i just reread my last post there and reading it now it kinda reads a bit harsh. Wasnt meaning it to man. Hope you didnt take it that way. Havent been sleeping well lately with everything going on at the same time. Stress at work, then dealing with the renovations of my house, the truck and now the sleeping issues. (Getting maybe an hr or 2 of solid sleep before fighting the rest of the night to stay asleep for work) I swear i need a vacation away from everything but cant afford one either.
 

d-kuzmen

Master Ford Tech
2,094
75
Connecticut
Wow i just reread my last post there and reading it now it kinda reads a bit harsh. Wasnt meaning it to man. Hope you didnt take it that way. Havent been sleeping well lately with everything going on at the same time. Stress at work, then dealing with the renovations of my house, the truck and now the sleeping issues. (Getting maybe an hr or 2 of solid sleep before fighting the rest of the night to stay asleep for work) I swear i need a vacation away from everything but cant afford one either.

Lol sounded fine to me. Get some sleep
 
Lol sounded fine to me. Get some sleep
Been trying. I sleep solidly for 1.5-2 hrs. Then i wake up for no reason. I end up fighting for 30-45 mins to get back to sleep. Only to sleep for maybe another 15-20 mins to start the fight all over again.
 

d-kuzmen

Master Ford Tech
2,094
75
Connecticut
Been trying. I sleep solidly for 1.5-2 hrs. Then i wake up for no reason. I end up fighting for 30-45 mins to get back to sleep. Only to sleep for maybe another 15-20 mins to start the fight all over again.
I feel your pain. I’m on meds for that.
 
6DA5F13A-5AA7-4CE7-9A23-8A4D18452134.jpegA9D6B994-4CB7-47E4-AC00-C96105726E00.jpeg

Got the last piece to make me an air leak tool. To late in the day to try today. So hopefully next week i can try on my days off.
 

CowboyBilly9Mile

Charter Member
7,110
435
E WA state.
^^^ Your patience and determination are impressive, I know it's just a matter of time until you figure out what's wrong and fix it. :)
 
^^^ Your patience and determination are impressive, I know it's just a matter of time until you figure out what's wrong and fix it. :)

I just hate being stretched so thin atm. By time i get home its to dark out and to late to do anything with it.
 
Tried out the home made tool. And found the cause.

7C086086-74C1-4753-A50B-7DF82AEF2902.jpeg

18662CDC-FD28-4558-8C36-2F879BDD4F07.jpeg

7F26970F-7960-4DE9-948F-1CF4D1760F7E.jpeg

Pretty sure these pieces are supposed to stay in the injector.

9D441C69-7062-4AA4-B1E9-09A80770693C.jpeg

A9BE1E82-E152-406B-9D79-D31C7A6D6D8E.jpeg

Good thing i had spares.

68FC0398-A9C6-45DC-ABE5-E8B00DA1440A.jpeg

Ill post videos later.
 

When i could finally air leak test the system.... ironically i had the beat the little heat shield back from the ICP sensor to get the socket in there to pull it... but no biggie...

annoyingly that was the only bad seal... its sad that a .30c oring can kill an entire engine...


but least its running again...
 

d-kuzmen

Master Ford Tech
2,094
75
Connecticut
Nice. Glad you got her up and running. Atleast you didn’t have to buy a $200 injector. I’ve seen them come apart and the pieces end up in the oil pan.
 
Nice. Glad you got her up and running. Atleast you didn’t have to buy a $200 injector. I’ve seen them come apart and the pieces end up in the oil pan.

Ive had one before where that micro bolt on the coils snapped. Small bit ended up caught in the freeze plug. The other half of the bolt ended up pinned against the rocker so it didnt come out.

I thought about buying another since its the only one on that side that hasnt been replaced yet. But id be waiting 3 days for it to be shipped into the dealership
 
image.jpg

Just curious. Is that a normal ipr reading for idle?? Was hard to start today but thinking that was because its still got trapped air since i havent driven it anywhere yet. When i let it idle up to operating temp the icp dropped down to 580 at idle. Never went below that though. From what i read elsewhere everyone says 680 is normal at warm idle. But dunno.

Nice thing is the left and right bank of the engine seems to have evened out temp wise now.

image.jpg
 
Last edited:

d-kuzmen

Master Ford Tech
2,094
75
Connecticut
I had one cold idling today at 800. I would say 580 warm is good. Yes it’ll give you a long crank until the air is purged out of the system. One good rip down the road usually takes care of it.
 
Ill have to try taking it somewhere again. Been leery to take it out with the long cranks. Thought something else was still going on.

Injector 3 still giving intermittent responses on the injector buzz test. Sometimes ticks sometimes doesnt. Is this that stiction thing i hear about??
 

d-kuzmen

Master Ford Tech
2,094
75
Connecticut
Ill have to try taking it somewhere again. Been leery to take it out with the long cranks. Thought something else was still going on.

Injector 3 still giving intermittent responses on the injector buzz test. Sometimes ticks sometimes doesnt. Is this that stiction thing i hear about??

The stiction is most noticeable cold. Usually the truck will run rough depending how many injectors are sticking for a short time after first cold start. Normally goes away as the engine warms up and the injector becomes less “sticky” as oil temps come up. Do a cold click test and one after you warm it up. You’ll probably hear a difference. Back in the day ford attempted to help reduce it. They came out with a new ficm program, to aid in warming the injector by cycling all the injectors when the key way turned on. I don’t think it really worked.
 
The stiction is most noticeable cold. Usually the truck will run rough depending how many injectors are sticking for a short time after first cold start. Normally goes away as the engine warms up and the injector becomes less “sticky” as oil temps come up. Do a cold click test and one after you warm it up. You’ll probably hear a difference. Back in the day ford attempted to help reduce it. They came out with a new ficm program, to aid in warming the injector by cycling all the injectors when the key way turned on. I don’t think it really worked.

Thats actually what i been doing. When its cold #3 doesnt tick. When its warmed up it does.

Heard about that warming injector programing. Everything ive heard on it as well sounded like it never did what they wanted it to. But never heard the specifics on it till now.
 
Top