Join Our Ford Truck Forum Today

Document your Ford truck project here and inspire others!

96 F250 headlight troubles

I have a 1996 f250 and I am having problems with the headlights. I used the truck the previous day and everything worked fine but now they don't want to turn on at all. Now it has an HID kit so I figured that was the problem but I put my old headlight in just to see what it does and I only got High beam so now i know it's something with the truck itself. I did some looking and people who had similar problems said a new dimmer fixed the problem. I happened to have an extra one laying around so I put it on but it made no difference. So now I am sort of lost. I get high be with stock halogen bulb but nothing with my HID's. Any help is appreciated!
 

dustybumpers

don't play well w others
When you say new dimmer, are you referring to the multi function switch/ turn signal?
Your truck does not have a floor dimmer switch. last year for that was 91
 

dustybumpers

don't play well w others
Probably the headlight switch has overheated then.
You will have to pull the dash bezel to get to it. When you pull the harness off the back of the switch, you will see that the harness has partially melted and needs to be replaced as well. I think Napa makes a kit for this

If you are going to run HID headlights, you are going to have to install relays in the wire going to each light to lighten the amp load on that circuit, or you will create too much heat at the switch
Headlights are NOT fused
 
I am going to go see if the switch has went out in a little bit here when it stops raining but I'm still not too sure because like I said the will turn on just no low beam. Except for my HID's which don't turn on at all
 

dustybumpers

don't play well w others
Did you pull the harness off the switch?
Usually when the switch gets hot, it unpins the wires from warping where they connect to the switch
 
I unhooked the wiring harness from the switch and jumped it connecting the two correct pins and the headlights did not come on but it powered them as if I turned the headlights on
 

dustybumpers

don't play well w others
I unhooked the wiring harness from the switch and jumped it connecting the two correct pins and the headlights did not come on but it powered them as if I turned the headlights on
Not sure what you are saying here.... You jumped the wires and added power, and the lights came on?
Sounds like a bad headlight switch, unless I misunderstand what you are saying
 

dustybumpers

don't play well w others
Have you checked the grounds to the headlights?
Added outside power to the harness to see if the power to the switch is the problem?
 
When I say I jumped them i mean I unplugged the headlight switch and with a piece of wire connected the two prongs for the headlights. But they still didn't turn on
 

dustybumpers

don't play well w others
Did you take a test light, and test the harness ( plug) for power?
check all connections.
 
Top