Ford Truck Fanatics  



Home Gallery TOTM New Posts My Threads / My Replies Links Sponsors Calendar Arcade Calculators Fliers
Go Back   Ford Truck Fanatics > F-Series > Generations 8-9

Generations 8-9 1987-1996 F150 + 1987-1997 F250, F350

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 11-03-2017, 03:35 PM
Kaajot Kaajot is offline
 
Join Date: Jul 2014
Posts: 80
Kaajot is on a distinguished road
Question Windshield Wiper Fluid Pump Not Pushing Fluid Through Line After Replacement & Was Pushing for Several Weeks

1992 F150, 4.9L 300

I replaced the Wiper Fluid Pump and Reservoir, reattched assmbly, etc. The blades move according to speed selection, and they move when pressing to request cleaning fluid.

However, the fluid again recently stopped coming on request for a cleaning swipe. I checked, no leaks, hose is attached, wiper fluid pump appears to be connected.

I replaced the CB that controls wiper connectvity in the lower left, no change -- no fluid on request.

QuestioN: Any other cbs/relays or components I should be inspecting? Else I think I'm looking at a crimped wire repair near the fluid pump by the driver side headlight (in the wiper fluid container pump slot).

Before I tear this thing apart again (since the retaining clip is what forced me to buy a new pump, the old pump worked fine but the clip is not sold separately at advance), I'd rather exhaust all other options. I'd hate to buy another pump if I damage the retaining clip when working on it.
Reply With Quote
Sponsored Links
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:13 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Ford Truck Fanatics is not affiliated with or endorsed by Ford Motor Company.