Ford Truck Fanatics  



Home Gallery TOTM New Posts My Threads / My Replies Links Sponsors Calendar Arcade Calculators Fliers
Go Back   Ford Truck Fanatics > Engines > 289, 302, 351W

Reply
 
Thread Tools Display Modes
  #1  
Old 10-28-2015, 08:04 PM
Medic2DaResq's Avatar
Medic2DaResq Medic2DaResq is offline
medic2DaResq
 
Join Date: Dec 2012
Location: Oklahoma
Posts: 9
Medic2DaResq is on a distinguished road
no juice to fuel pump, Help Help Help

I have 1993 bronco, replaced fuel pump 3 wks ago, today while driving it suddenly began losing power and finally died. Wouldnt start back. Found out fuel pump not kicking on at all. Checked wires at pump, checked relay and pump fuse, all good. Truck started right up after ,hat but only ran for 5 min, now wont start and pump not kicking on. Please help a girl out.
__________________
Theresa
Reply With Quote
Sponsored Links
  #2  
Old 10-28-2015, 08:10 PM
SuperCab's Avatar
SuperCab SuperCab is offline
Super Moderator

Super Moderator
 
Join Date: Sep 2008
Location: Montana
Posts: 9,870
SuperCab has a reputation beyond reputeSuperCab has a reputation beyond reputeSuperCab has a reputation beyond reputeSuperCab has a reputation beyond reputeSuperCab has a reputation beyond reputeSuperCab has a reputation beyond reputeSuperCab has a reputation beyond reputeSuperCab has a reputation beyond reputeSuperCab has a reputation beyond reputeSuperCab has a reputation beyond reputeSuperCab has a reputation beyond repute
Is there power at the relay when the pump does not function?
__________________
-Frank

2011 F-150 XLT SuperCrew EcoBoost

Quote:
Originally Posted by Austin View Post
I have some other options if those don't work.

What's your view on sheep?
Reply With Quote
  #3  
Old 10-28-2015, 08:33 PM
Medic2DaResq's Avatar
Medic2DaResq Medic2DaResq is offline
medic2DaResq
 
Join Date: Dec 2012
Location: Oklahoma
Posts: 9
Medic2DaResq is on a distinguished road
Yes there is, but there is no power at the pump for sure
__________________
Theresa

Last edited by Medic2DaResq; 10-28-2015 at 08:35 PM. Reason: added too
Reply With Quote
  #4  
Old 10-28-2015, 08:48 PM
cbaker65's Avatar
cbaker65 cbaker65 is offline
 
Join Date: Apr 2014
Location: Mcfarland,Calif.
Posts: 4,897
cbaker65 has a reputation beyond reputecbaker65 has a reputation beyond reputecbaker65 has a reputation beyond reputecbaker65 has a reputation beyond reputecbaker65 has a reputation beyond reputecbaker65 has a reputation beyond reputecbaker65 has a reputation beyond reputecbaker65 has a reputation beyond reputecbaker65 has a reputation beyond reputecbaker65 has a reputation beyond reputecbaker65 has a reputation beyond repute
It sounds like a loose or dirty conection,also the relay's contacts could
be corroded,they act like a set of points!
check out any plug type conectors an make sure they aren't corroded an dirty!...
__________________
CB

Im not a bum,Im on vacation!....

Last edited by cbaker65; 10-28-2015 at 09:45 PM.
Reply With Quote
  #5  
Old 10-28-2015, 09:30 PM
SuperCab's Avatar
SuperCab SuperCab is offline
Super Moderator

Super Moderator
 
Join Date: Sep 2008
Location: Montana
Posts: 9,870
SuperCab has a reputation beyond reputeSuperCab has a reputation beyond reputeSuperCab has a reputation beyond reputeSuperCab has a reputation beyond reputeSuperCab has a reputation beyond reputeSuperCab has a reputation beyond reputeSuperCab has a reputation beyond reputeSuperCab has a reputation beyond reputeSuperCab has a reputation beyond reputeSuperCab has a reputation beyond reputeSuperCab has a reputation beyond repute
I agree, sounds like maybe a bad connection or the relay is going bad...
__________________
-Frank

2011 F-150 XLT SuperCrew EcoBoost

Quote:
Originally Posted by Austin View Post
I have some other options if those don't work.

What's your view on sheep?
Reply With Quote
  #6  
Old 10-29-2015, 08:20 AM
blacksnapon's Avatar
blacksnapon blacksnapon is offline
Super Moderator

Super Moderator
 
Join Date: Feb 2007
Location: waynesville,mo.
Posts: 9,452
blacksnapon has a reputation beyond reputeblacksnapon has a reputation beyond reputeblacksnapon has a reputation beyond reputeblacksnapon has a reputation beyond reputeblacksnapon has a reputation beyond reputeblacksnapon has a reputation beyond reputeblacksnapon has a reputation beyond reputeblacksnapon has a reputation beyond reputeblacksnapon has a reputation beyond reputeblacksnapon has a reputation beyond reputeblacksnapon has a reputation beyond repute
inertia switch
__________________
ase master tech--fmc senior master tech (retired)
Reply With Quote
  #7  
Old 11-03-2015, 06:44 PM
Medic2DaResq's Avatar
Medic2DaResq Medic2DaResq is offline
medic2DaResq
 
Join Date: Dec 2012
Location: Oklahoma
Posts: 9
Medic2DaResq is on a distinguished road
I hooked fuel pump directly to battery to check pump, all I got was little bit of spark. Is pump bad or could it be a ground wire?
__________________
Theresa
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:23 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Ford Truck Fanatics is not affiliated with or endorsed by Ford Motor Company.