Ford Truck Fanatics  



Home Gallery TOTM New Posts My Threads / My Replies Links Sponsors Calendar Arcade Calculators Fliers
Go Back   Ford Truck Fanatics > F-Series > Generation 1

Generation 1 1948-1952 F1 thru F8

Reply
 
Thread Tools Display Modes
  #1  
Old 02-07-2018, 09:58 AM
wcm71 wcm71 is offline
 
Join Date: Feb 2018
Posts: 1
wcm71 is on a distinguished road
issues with my 1950 f1

Hey guys
Im having some issues with my F1. It started three days ago truck started hesitating and running rough when initial acceleration from take off also noticed it when driving after letting off and reacceleration. I changed the electric fuel pump and the inline filterat the carb. Here's a little info on motor it"s an 302 with a Edelbrock 650. I boult the truck 6 months ago been driving it almost everyday since truck runs great no issues other then front drum breakes need to go away and need wiper moter Thank god for rainX...
If anyone has an idea i would love to hjere from you Thanks
Reply With Quote
Sponsored Links
  #2  
Old 02-13-2018, 07:29 AM
Jasperrc's Avatar
Jasperrc Jasperrc is offline
Texas Chapter member
 
Join Date: Jan 2016
Location: North Central Texas
Posts: 475
Jasperrc is a splendid one to beholdJasperrc is a splendid one to beholdJasperrc is a splendid one to beholdJasperrc is a splendid one to beholdJasperrc is a splendid one to beholdJasperrc is a splendid one to beholdJasperrc is a splendid one to behold
First of all, welcome to FTF!

Love to see some pics of your F1

The first thing I would do would be to check all your vacuum hoses and caps for leaks. A vacuum leak can cause rough running issues.
__________________
- Russell

'77 F100 Flareside

"If it jams, force it. If it breaks, it needed replacing anyway."
Reply With Quote
  #3  
Old 02-13-2018, 07:44 AM
smokey's Avatar
smokey smokey is offline
hitech hillbilly

Admin
 
Join Date: Mar 2008
Location: Garrett Co. Maryland
Posts: 13,020
smokey has a reputation beyond reputesmokey has a reputation beyond reputesmokey has a reputation beyond reputesmokey has a reputation beyond reputesmokey has a reputation beyond reputesmokey has a reputation beyond reputesmokey has a reputation beyond reputesmokey has a reputation beyond reputesmokey has a reputation beyond reputesmokey has a reputation beyond reputesmokey has a reputation beyond repute
Welcome to FTF
I agree with Russell sure sounds like a vacuum leak or carb issue.
__________________
_Find more about Weather in Grantsville, MD
Click for weather forecast
________________
Randy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:44 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Ford Truck Fanatics is not affiliated with or endorsed by Ford Motor Company.